unexpected error

Sep 15, 2009 at 8:01 AM
Edited Sep 15, 2009 at 1:18 PM

Hi!

In preparation for my diploma thesis I should deal with a WSS-based CMS and so I´ll take a look on CS.NET. After installing and deploying of the solution and creating a new web-collection I created a new publishing page, wrote something in an article and after a click on "publish"  I get the note "an unexpected error has occured"  each time. Using Server 2003 R2 Enterprise SP2 English and WSS v3.0. What are the steps to find the source of this error? In which logfiles I have to look? 
Would appreciate for any help.

I set customErrors mode=”OFF” and SafeMode callStack=”true", then the response is:

Exception Details: System.NullReferenceException: Object reference not set to an instance of an object.

Source Error: 

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.  

Stack Trace: 


[NullReferenceException: Object reference not set to an instance of an object.]
   CompleteSharepoint.NET.Web.UserControls.PageEditingToolbar.CheckIn(Boolean publish) +1183
   CompleteSharepoint.NET.Web.UserControls.PageEditingToolbar.Publish_Click(Object sender, EventArgs e) +40
   System.Web.UI.WebControls.Button.OnClick(EventArgs e) +111
   System.Web.UI.WebControls.Button.RaisePostBackEvent(String eventArgument) +110
   System.Web.UI.WebControls.Button.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +10
   System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +13
   System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +36
   System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1565

 

Thank you!

Coordinator
Sep 16, 2009 at 3:03 PM

Have you enabled required settings in web.config? Please refer to the developers guide for what lines you need to add/enable on your web.config.

 

cheers,

Tommy