Permissions

Aug 20, 2009 at 11:00 PM

Great solution!  I was able to install in a clean WSS environment and everything appears to be working.  The only issue I'm having is that users with only View permissions get the "Error: Access Denied" page.  If I add the user to the owners group they can see the page.  When they are part of the Contributor group they can check-out/in and edit the page properties, including content but still cannot view the page.  I checked to make sure everything was checked in including the page itself, the layout page and the master page and they are all checked-in and published.

Any ideas?

 

Thanks again,

Eric

Coordinator
Aug 20, 2009 at 11:04 PM

Eric,

Are you currently using CS.NET's website? There is a list in root called Application Settings. Make sure your Read-only users can edit that list. I've created a functionality on the homepage where if someone visits the homepage and download page, it will automatically increment the counter in that list.

Another thing, make sure that you have published the page to version 1.0 at least. As with normal behaviour of Sharepointl ist, Read-only users can only - by default - see major versions unless you change the versioning settings in the Pages library to allow read-only users access draft items.

Hope this helps,
Tommy

Aug 20, 2009 at 11:23 PM

Hi Tommy,

Wow thanks for such a quick response.  That was it.  It is working now.  Now all I need to do is figure out how to hide the publishing box so it isn't displayed for non-editors.

What a great solution!

Thanks,

Eric

Sep 7, 2009 at 1:02 PM

I have the same problem. My readers can't view the home page. My pages are published. I have in the log this error "Failed to find the content type schema for ct-1033-0x0162d9afca87664c8e83cf6a63ff35 while caching feature data." What is it?

Thanks

Coordinator
Sep 9, 2009 at 5:07 AM

Danieleg,

Go to site content types and confirm that all content types are in there. Sometimes upon creating sites in Sharepoint, the content types are corrupted. What you need to do (if this is the case) is delete the site collection and re-create. It should fix the issue.

 

Cheers,
Tommy